3DS MAx 2016 SP4 conection error
2 2

18 posts in this topic

Hi Ftrackers!

I try to install FTrack Connect with 3DS Max integration and Connect runs ok, but I can't use the 3DS Max integration, because I don't see the action in to my Actions.

I install vc-redis_x64 (Windows 7 Enterprise), and copy *.ms files to scripts/startup and move all dll's files to plugins folder (not stdplugins), but I receive this warning:
 
Maxscript auto-load script error
C:\Program Files\Autodesk\3ds Max 2016\scripts\Startup\initftrac.ms
Runtime error: File not found


This file (initftrac.ms) is inside the scripts/startup folder.

 

Share this post


Link to post
Share on other sites
I solve this issue, moving *.py and *.pyc to:
C:\Program Files\Autodesk\3ds Max 2016\scripts\Python

But now I have this warning:
Runtime error: Line 7 <module>()
<Type 'exceptions.ImportError'> No Module named ftrack

Share this post


Link to post
Share on other sites

Hi @Bisnis3d
have you been trying installing the Visual C++ 2015 Redistributables ?

 https://www.microsoft.com/en-us/download/details.aspx?id=48145

You can find a list of all the requirements for the 3dsmax integration here :
https://bitbucket.org/ftrack/ftrack-connect-3dsmax/src/87f32108b3338533a9a3f5c85e44db000450406f/doc/installing/installing.rst?at=master&fileviewer=file-view-default

If you can gather some other informations please feel free to post them here.
Cheers.

L.

Share this post


Link to post
Share on other sites
17 minutes ago, lorenzo.angeli said:

Hi @Bisnis3d
have you been trying installing the Visual C++ 2015 Redistributables ?

 https://www.microsoft.com/en-us/download/details.aspx?id=48145

You can find a list of all the requirements for the 3dsmax integration here :
https://bitbucket.org/ftrack/ftrack-connect-3dsmax/src/87f32108b3338533a9a3f5c85e44db000450406f/doc/installing/installing.rst?at=master&fileviewer=file-view-default

If you can gather some other informations please feel free to post them here.
Cheers.

L.

Hi Lorenzo,

Yes, I installed VC ++ Redist before installing ftrack.connect, and all requirements are ok in my PC.
Can it be a file permissions issue? The user account of windows 7 is not an administrator, it is a basic user.

Thanks!

Share this post


Link to post
Share on other sites
4 minutes ago, lorenzo.angeli said:

Hi, some basic questions ,

  • is the VC++ been installed as administrator,
  • was it the 2015 version ,
  •  have you been rebooting after the installation ?

Cheers.

L.

Yes, VC++ was installed by the System Admin.

Yes 2015 - vc_redist.x64 - Windows 7 Enterprise

Yes, I was reboot after installing.

Share this post


Link to post
Share on other sites
4 minutes ago, lorenzo.angeli said:

mhhh, have you been trying running connect as administrator , by any chance ?

just to see if does releate to permissions as you were suggesting.

Cheers.

L.

I try to run 3ds max and connect from administrator account today and reply here.

Thanks

Share this post


Link to post
Share on other sites
5 hours ago, lorenzo.angeli said:

mhhh, have you been trying running connect as administrator , by any chance ?

just to see if does releate to permissions as you were suggesting.

Cheers.

L.

Running from admin account have the same error, launching from Connect and launching from 3ds Max Icon too.

It isn't a permission problem...

Share this post


Link to post
Share on other sites

Hi @Bisnis3d, sorry for the delay on getting back to you.
We updated our version of 3dsmax to match yours and we found similar issues, but we sorted them out.
The root cause we found for this error, is that something is modifying the PATH (which works for libraries as well as exe) variable in the system,
prepending some library path to it.

This does clash with the ones which are bundled with ftrack-connect-3dsmax and makes raise the error you found.

So, long story short, what's the solution ?
Have a look at other plugins or software you might have been installing and/or check your environment variables if are modified to change the PATH one to something custom.
The best option, of course, would be to test on a fresh machine.

ps.just to be sure , also update (just for security) the  VC ++ Redist  version to the latest.  https://www.microsoft.com/en-us/download/details.aspx?id=53840
 

Let us know !

L.

Share this post


Link to post
Share on other sites

Hi Lorenzo, but I can't try to change any for now, because the work charge this week and next week are very large...

I a few days I try to solve the problem with the administrator and your information.

Stay in contact.

Share this post


Link to post
Share on other sites
On 24/03/2017 at 3:39 PM, Bisnis3d said:

 

Hi Lorenzo, but I can't try to change any for now, because the work charge this week and next week are very large...

I a few days I try to solve the problem with the administrator and your information.

Stay in contact.

 

Have been able to get any further with this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2