Ftrack Connect Python3
0

7 posts in this topic

Hi,

I'm currently testing ftrack to see if I can integrate it into my workflow. Sadly, the issue I have is that ftrack-connect doesn't seem to be working with Python3 (which is what I have been using to make my tools in blender and Houdini)

When I'm launching houdini from ftrack-launcher, I don't have access to 'Import Asset' tool, or anything related to ftrack. I also tried to import the ftrack_api to see if that was working but it's not neither. I got this message:

File "<stdin>", line 1, in <module>
AttributeError: module '__main__' has no attribute 'FtrackDialogs'

Is there any plan to upgrade it to python3 so we can use it with python3 build of for example Houdini18.5 ?

Share this post


Link to post
Share on other sites

hi @matthieu, 

we are actively working on connect for python on 3 .If you like to give it a go , you can try this branch
This new version though is not compatible with the current integrations ., but we are working on solutions to make them work back, just not there yet.

In regard of your error, seems strange to be coming from the api , as it seems to be referring to Dialogs, which are just a ui thing.

There'll be some news soon.
Cheers.
L.

 

Share this post


Link to post
Share on other sites

hi @Lorenzo

Thanks, glad to hear that. So I got the branch copied locally on my computer.

I'm currently trying to build it. For now, I get an error telling me pySide-rcc could not be found, but I think it's coming from my system, as I found the 'pyside2-rcc.exe' file, it's in my path but I can't start it

Currently looking into it, I will tell you how it goes

Edit:

I found out that it was coming from my PySide2 version. The latest version (v5.15.1) doesn't seem to have a pyside2-rcc working. I had to reverse to 5.13.1 .

Here is a link showing exlpaining it: https://bugreports.qt.io/projects/PYSIDE/issues/PYSIDE-1171?filter=allissues

 

Edited by matthieu

Share this post


Link to post
Share on other sites

Small Update:

I've now tried to launch ftrack-connect using 

python -m ftrack_connect

as they say in the documentation. I then get a Server error:

ftrack_api.session.Session - Server reported error: InvalidCredentialsError(Invalid username specified in header "ftrack-user". Please verify that the header is set correctly and that a user with that username exists and is active in ftrack.)

I have two environment variables, one called 'FTRACK_SERVER' and the other 'FTRACK_API_KEY'. For the API_KEY, I took the one which is visible in my account settings. Is there anything else needed to do?

Thanks for the help

Share this post


Link to post
Share on other sites

@matthieu Thanks for the headup on the PySide version! 

if you are using the pyside2 branch of connect (which is also python3) you should set :

FTRACK_API_USER
FTRACK_SERVER
FTRACK_API_KEY


the other legacy envs (such as LOGNAME) have been deprecated in that branch.

hope it helps.
L.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0