Jump to content

Problem updating to ftrack-python-api 1.8.1

Recommended Posts

We're running Centos 7 which has a python version that identifies as 2.7.5 (even though it probably contains many backported patches from later versions). Unfortunately, this prevents us from using pip to update ftrack-python-api from 1.8.0 to 1.8.1. (the previous version didn't have the requirement of Python >=2.7.9).

Is there something in 1.8.1 that warrants the minimum Python version? I'll download it manually for now to see if it works...

Link to post
Share on other sites

Hi @Tilt , having the python version to >= 2.7.9 has always been a soft requirement for the api, but was never enforced through the installation process itself.
Once the amount of issues raised by having python not correct has got to an alarming level we decided to raise the requirement to hard.

My suggestion would be to install a newer version of python on C7 (quite a straight forward process).

Hope it helps.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...