Jump to content

ftrack connect linux - bad escape (end of pattern) at position 19


Recommended Posts



We're tyring to get ftrack connect up and running. We have a baseline install of Rocky8. The app launches fine and installs the plugins ok too.

Though after installing the plugins when it restarts we invariably get what seems to be a python .re error. The number and what plugins we install doesn't make any difference.

The error seems to be in the core: ui/application.py. Once we click Ok the app just closes itself.

We're migrating our pipeline and evaluating ftrack at the moment but this seems like a show stopper. Any thoughts?

Attaching a screengrab and the logs.



Rocky Linux 8

Python 3.6

ftrack-Connect-2.1.1-C8 / ftrack Connect-2.0.0rc6-C8 (tried an earlier release to rule out a specific release bug. Happens in both versions though)





ftrack_connect.log ftrack_application_launcher.log

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
On 11/17/2023 at 5:42 PM, Annabelle said:

Solution: Remove all Users/henriknorin/Documents/ftrack/dev/... from the pasterize, futurize and normalizer files. The #!Users/henriknorin/Documents/ftrack/dev/... is a path, not a comment and it points to an unexisting python lib on your system. 

Definintely a step towards the solution. Unfortunatelly, didn't work in my case although the error message changed from "position 17" to "position 19"... I even tried to replace the above mentioned line with 


instead of just removing it, with no success either...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...