Jump to content

ftrack rv integration


Recommended Posts


I am trying to hook up rv with ftrack but I ran into some problems.

I have installed ftrack connect and the ftrack plugin for RV. 

Now I have an animation and I can review it via the webplayer just fine. If I do Review -> Launch RV, rv does open promptly but doesn't display anything. 

This is what I see in the console in RV:

INFO: received URL 'rvlink://baked/202d666c616773204d6f64654d616e616765725072656c6f61643d66747261636b2066747261636b55726c3d68747470733a2f2f776f6f67612e66747261636b6170702e636f6d20706172616d733d277b22656e746974794964223a5b2232613063326537322d383936622d313165372d393262392d306135383061653430363063225d2c22617574685f746f6b656e223a5b2232613231356465632d383936622d313165372d616436662d306135383061653430363063225d2c22656e7469747954797065223a5b2274656d7064617461225d7d27' 
INFO: decoded URL 'rvlink:// -flags ModeManagerPreload=ftrack ftrackUrl=https://wooga.ftrackapp.com params='{"entityId":["2a0c2e72-896b-11e7-92b9-0a580ae4060c"],"auth_token":["2a215dec-896b-11e7-ad6f-0a580ae4060c"],"entityType":["tempdata"]}'' 

which looks to me like something is working.. 

What do I miss here?

Thanks in advance for any hints!


Link to comment
Share on other sites


If you are able to launch RV with the integration from ftrack Connect, but not via the review menu, that seems to indicate that either the legacy Python API or credentials has not been made available to the integration. See the getting started instructions here.

No versions found seems to indicate that there are no versions published linked to the selected task. Can you try opening the Asset version directly, to verify if that works?

Link to comment
Share on other sites

I've done some more investigations on my end, and I suspect that the issue is caused by a combination of two things:

  1. The version is published to a task which is in the project root. 
  2. The task is being launched for review.

The issue is caused by legacy logic in how the versions are being fetched.

To work around the issue, you can either open the versions directly (from the version's sidebar with Assetversion at the top, select More -> Launch RV), or publish the version to a task within a object (e.g. a shot or asset build) in the project hierarchy.


Link to comment
Share on other sites

Hi Lucas,

thanks for looking!

So if I just click on the little icon, I get "opening local" and it shows the anim in rv - however when I make a note, I get a server error. (as attached)

If I right click on that icon and do review it doesn't load the animation.

I also tried to put the task into a folder "anims" but that didn't help either.




Link to comment
Share on other sites


For the issue with the task being directly on the project, you will need to re-publish a new asset for the issue to disappear. Technically, the Asset's parent can not be a project, it must be a TypedContext-derived object (e.g. Folder, Shot). If you open the version in the sidebar you can see this as "Linked to".

The server error occurs because no version is loaded in the right pane. It is unfortunate that a generic server error is shown, instead of a more appropriate message. I will report this as a bug. You can see no version is loaded as "No data found" at the top,. To be able to write notes, you must have a version in the right panel. I believe this might be related to the first issue.

Try the following,

  1. Right-click "Animation1 v2" in the versions spreadsheet and select "Review -> Play selection in RV"
  2. Once RV and the integration has loaded, double-click the thumbnail in the bottom panel to load it in the player and right panel.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...