Failed to connect to event server
4 4

10 posts in this topic

Hey everyone,

 

New ftrack user here trying to get started.  I installed ftrack connect on OS X 10.10.3, entered the server, user, and api key information and I get a rather nondescript error saying "Failed to connect to event server at https://SERVER URL" where SERVER URL is my ftrack url.

 

I'm not behind a firewall or anything and I've tried from multiple internet connections.  I verified that I can login via the website with the same credentials, but Connect isn't, well, connecting, from the desktop.

 

Any thoughts?

 

Rich

Share this post


Link to post
Share on other sites

Hi Rich,

 

Which version of Connect are you using when trying to connect?

 

We currently have two versions available on ftrack.com:

 

* 0.2.0 which only works together with ftrack 3.1+(not fully released yet)

* 0.1.13 which is for ftrack 3.0.x

 

To see which version of ftrack you are running, go to System Settings -> General Settings -> About in the web interface. You'll find System Settings in the menu in the top right corner.

 

Regards,

Share this post


Link to post
Share on other sites

Hi all,

 

I've got a similar problem.

Currently I am on a windows machine behind a proxy trying to get Connect 0.2.0 to communicate with ftrack 3.1.4.4319.

Since there is no way to enter any proxy settings in the app, Mattias from support pointed me to the "FTRACK_PROXY" environment variable.

With that in place using "user:password@server:port" I now get the "Failed to connect to event server at https://account.ftrackapp.com" error message.

 

Any ideas on how I could get that connection to work?

Cheers,
Carl

 

PS: I installed connect on a different machine without proxy (via a freshly downloaded "ftrack-connect-package-0.2.0-amd64.msi" file) and it says in the about-window "Version: 0.1.10". That's probably just a mistake, but adds to the confusion. 

Share this post


Link to post
Share on other sites

Hello! I'm running into this error as well, but it's not consistent. When I open Maya I don't get any errors and a connection is successfully made to the servers.

When I open Houdini I'm getting this:

Traceback (most recent call last):
     File "", line 11, in 
     File "D:\Git_Stuff\mb-armada\modules\mb_shipyard\mb_marina_major_minor\main_mmm.py", line 8, in 
     ftrack_data = query_ftrack_data.query_data()
     File "D:\Git_Stuff\mb-armada\modules\mb_shipyard\mb_marina_major_minor\packages\mmm_api\query_ftrack_data.py", line 24, in query_data
     session = ftrack_api.Session()
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\common.zip\ftrack_api\session.py", line 254, in __init__
     self._discover_plugins(plugin_arguments=plugin_arguments)
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\common.zip\ftrack_api\session.py", line 1328, in _discover_plugins
     self._plugin_paths, [self], plugin_arguments
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\common.zip\ftrack_api\plugin.py", line 120, in discover
     **selected_keyword_arguments
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\resource\hook\ftrack_location_compatibility\register_proxy_location.py", line 78, in register
     ftrack.EVENT_HUB.connect()
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\common.zip\ftrack_location_compatibility\_monkey_patch.py", line 21, in connect
     return ftrack.EVENT_HUB._connect()
     File "D:\Git_Stuff\mb-armada\modules\dependencies\ftrack_connect\common.zip\FTrackCore\api\event\hub.py", line 163, in connect
     .format(self.getServerUrl())
    EventHubConnectionError: Failed to connect to event server at https://firstborn.ftrackapp.com.

I've been using the line below to build my pane tab in a custom 123.py script.

hdefereval.executeDeferred(lambda: make_panel())

I'm guessing the issue has something to do with when the panel is being built because when I create the python panel again by going to New Pane Tab Type> Python Panel> mb_MMM it queries the ftrack servers successfully and correctly builds the panel tab. 

I should mention that I'm still on connect 0.7.6. Will updating to 1.0.1 solve this problem? I've tried updating before and ran into some different issues which are preventing me from properly testing.  So I'm hesitant to move on while some bugs are still prevalent in this version of  my pipeline.

Share this post


Link to post
Share on other sites

Hi @Mike, is hard to tell without more debug information, but could be related to the ssl library shipped with the python version embedded with houdini.
Can you please provide what houdini and python version are you using ?
If you have a chance please try to see using a different interpreter whether does help.

Looking forward to hear more !
L.

Share this post


Link to post
Share on other sites

Sorry for the delay, got pulled away from this for a bit.

 

I did some digging and found that some of my ftrack env variables point to paths that no longer exist due to the updated connect folder structure.  I'll make some changes and will let you know how it goes.

Share this post


Link to post
Share on other sites

I was able to get ftrack running with a few updates to my env variables did the trick, but I'm pretty stumped on how to proceed with this new issue that I'm making in a different thread for.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
4 4