Photoshop ftrack not connected to event server
1 1

3 posts in this topic

Hello, 

 

We just started using ftrack and are testing it, so this is probably a noob question :) 

 

I just tried to install the extension for Photoshop. But when I click on Publish, it says Error: Unable to publish; Not connected to event server. 

Also when choosing an Action on the website I dont get Photoshop as an option. 

 

In the Photoshop extension debug info it says this:

 

 

Context

-------
user: null
entityId: null
entityType: null
 
Event Server
-----------
Connected: false
 
Last published event
--------------------
 

 

 

I also use Maya. Maya works. 

The thing is I got Maya installed on my C: drive , but all Adobe Programms are installed on my E: drive. 

 

I think ftrack connect doesnt find my Adobe programms, because they are not installed in the C drive? 

How do I tell ftrack connect to look for programms also installed on my E: drive? 

 

Or where do I change those settings from the debug info (user, entityId and entityType) ? 

 

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for reaching out to us.

 

Photoshop needs to be launched from Action in the web interface for the publish to work. That is the reason the debug information is all empty. For more information on launching, see the documentation.

 

ftrack connect currently looks for the programs in their default installation paths. To get it to pick Photoshop as installed on your E: drive, you modify the search path for the launch hook, used by connect to find and launch the extension. To do so, locate the file ftrack_connect_adobe_hook.py under the directory resource/hook/ in the ftrack connect installation directory. Edit the file and modify the prefix on line 187, to match your installation disk.

 

Another alternative, which might be easier, is to create a shortcut/link from your Adobe install directory and place that in C:\Program Files. However, I am not completely sure that this works for all applications.

 

 

Regards,

Lucas

Share this post


Link to post
Share on other sites

Ok now it works. :)

 

I first tried to copy shortcut links to the C: drive, but that didnt work.

 

Then I changed that ftrack_connect_adobe_hook.py script, pointing to my E: drive. This works now, ftrack now finds Photoshop when pressing the Action button.

 

Thank you very much :lol:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1