SSLError: Can't connect to HTTPS URL because the SSL module is not available.
0

10 posts in this topic

Hi guys:

I tried connect whit:

python2.7 /Volumes/Pipeline/sitename-efesto-toolbelt-0.3.0/bin/launcher.py

in send raise SSLError(e, request=request)

SSLError: Can't connect to HTTPS URL because the SSL module is not available.

[root@PyblishRG hquintanaro]# cat /etc/centos-release
CentOS Linux release 7.5.1804 (Core)

[root@PyblishRG hquintanaro]# uname -a
Linux PyblishRG 3.10.0-862.11.6.el7.x86_64 #1 SMP Tue Aug 14 21:49:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@PyblishRG hquintanaro]# echo $PATH
/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/hquintanaro/.local/bin:/home/hquintanaro/bin

[root@PyblishRG hquintanaro]# echo $PYTHONPATH
/home/hquintanaro/pyblish:/usr/local/bin/python2.7

[root@PyblishRG hquintanaro]# python --version
Python 2.7.5

[root@PyblishRG hquintanaro]# python2.7 --version
Python 2.7.15

[root@PyblishRG hquintanaro]# pip --version
pip 18.0 from /usr/lib/python2.7/site-packages/pip (python 2.7)

[root@PyblishRG hquintanaro]# pip list
Package                          Version   
-------------------------------- ----------
backports.ssl-match-hostname     3.5.0.1   
blivet                           0.61.15.69
chardet                          2.2.1     
configobj                        4.7.2     
coverage                         3.6b3     
cupshelpers                      1.0       
decorator                        3.4.0     
di                               0.3       
fros                             1.0       
iniparse                         0.4       
initial-setup                    0.3.9.43  
ipaddress                        1.0.16    
IPy                              0.75      
javapackages                     1.0.0     
kitchen                          1.1.1     
langtable                        0.0.31    
lxml                             3.2.1     
ntplib                           0.3.2     
perf                             0.1       
pexpect                          2.3       
pip                              18.0      
policycoreutils-default-encoding 0.1       
pyblish                          1.4.3     
pyblish-base                     1.5.3     
pyblish-lite                     0.6.4     
pyblish-maya                     2.1.2     
pyblish-modo                     0.0.2     
pyblish-qml                      1.8.2     
pycups                           1.9.63    
pycurl                           7.19.0    
pygobject                        3.22.0    
pygpgme                          0.3       
pyinotify                        0.9.4     
pykickstart                      1.99.66.18
pyliblzma                        0.5.3     
pyparted                         3.9       
PySide                           1.2.4     
python-augeas                    0.5.0     
python-dmidecode                 3.10.13   
python-linux-procfs              0.4.9     
python-meh                       0.25.2    
python-nss                       0.16.0    
pytz                             2016.10   
pyudev                           0.15      
pyxattr                          0.5.1     
pyxdg                            0.25      
scdate                           1.10.6    
schedutils                       0.4       
seobject                         0.1       
sepolicy                         1.1       
setroubleshoot                   1.1       
setuptools                       0.9.8     
six                              1.9.0     
slip                             0.4.0     
slip.dbus                        0.4.0     
urlgrabber                       3.10      
virtualenv                       16.0.0    
wheel                            0.24.0    
yum-metadata-parser              1.1.4

 

Share this post


Link to post
Share on other sites
forgot this:

[root@PyblishRG hquintanaro]# rpm -qa |grep openssl
openssl-libs-1.0.2k-12.el7.x86_64
openssl-1.0.2k-12.el7.x86_64
xmlsec1-openssl-devel-1.2.20-7.el7_4.x86_64
openssl-devel-1.0.2k-12.el7.x86_64
xmlsec1-openssl-1.2.20-7.el7_4.x86_64

 

 

 

Share this post


Link to post
Share on other sites

Hello Lorenzo:
I'm Hugo Quintana from Televisa Mexico.
We had contact with esteban.tovagliari@efestolab.uk and you.
We created a shared NFS resource for the Pipeline and Projects resources.
Which works correctly.
Install a new machine with centos 7 and python2.7.15, if I mount the resource in / Volumes / Pipeline.
And I execute the command:
python2.7 /Volumes/Pipeline/televisa-efesto-toolbelt-0.4.0/bin/launcher.py
I have the error:
SSLError: Can not connect to HTTPS URL because the SSL module is not available.

Share this post


Link to post
Share on other sites

Hello guys 

I’ve had contact  with Esteban and Lorenzo we were working in a project called Televisa efesto toolbelt 

According to my last test, following your instructions, I have now this result.
Working with Centos’s version 6 and the Python’s update 2.7.12 they work correctly when I use them in a centralized way.
Actually I’m trying to make the same process in a new machine with Centos 7  and Python 2.7.15 but when I run them in a centralized service I get this issue “SSLError: can’t connect to HTTPS URL because the SSL module is not available” 

I have some question about it: 

Do I have to run it locally? 
What’s going to happen with the centralized service? 

Thanks for the support

Greetings !

Share this post


Link to post
Share on other sites

Hi @hquintanaro
Are these error coming from the ftrack-connectg-package you have been dowloading from https://www.ftrack.com/en/portfolio/connect ?

ftrack-connect-package (on linux) should be able to run centrally, but is suggest first to test it locally.
If you do have errors try to see if you have any missing library regarding ssl.

Cheers.
L.

 

 

Share this post


Link to post
Share on other sites





If I download ftrack-connect-package from the url https://www.ftrack.com/en/portfolio/connect.
Operates correctly. If attached ftrack-connect-package, to the NFS share. The SSL error appears.
Try the first version of efesto-toolbelt, sent by you.
And it operates correctly on the NFS share.I sent you the log.

[hquintanaro@PyblishRG Documentos]$ python2.7 /Volumes/Pipeline/televisa-efesto-toolbelt/bin/launcher.py
127.0.0.1 - - [10/Oct/2018 10:56:20] "GET /?api_user=hquintanaro&api_key=ffffffffff HTTP/1.1" 200 -
[2018-10-10 10:56:23][INFO] root config_logging.py:configure_logging:108 | Saving log file to: /Volumes/Pipeline/televisa-efesto-toolbelt/logs/efesto_futils.log
[2018-10-10 10:56:23][INFO] root config_logging.py:configure_logging:108 | Saving log file to: /Volumes/Pipeline/televisa-efesto-toolbelt/logs/efesto_fstructure.log
[2018-10-10 10:56:24][DEBUG] efesto_fstructure.base.structure structure.py:get_mount_point:250 | Mount Point: /Volumes/Projects
[2018-10-10 10:56:24][DEBUG] efesto_futils.adetools adetools.py:__init__:26 | Setting up ade.
[2018-10-10 10:56:24][DEBUG] ade.manager.config config.py:__init__:27 | Using config_search_path: /Volumes/Pipeline/televisa-efesto-toolbelt/modules/plugins/efesto-fstructure/resources/ade_config
[2018-10-10 10:56:24][DEBUG] ade.manager.config config.py:__init__:49 | Config found: ['default']
[2018-10-10 10:56:24][DEBUG] efesto_futils.adetools adetools.py:__init__:34 | ade mount point set to /Volumes/Projects
[2018-10-10 10:56:24][DEBUG] ade.manager.template template.py:__init__:43 | Using template path: /Volumes/Pipeline/televisa-efesto-toolbelt/modules/plugins/efesto-fstructure/resources/ade_config/ade_template
[2018-10-10 11:04:01][INFO] root register_structure.py:register_common:12 | registering common
[2018-10-10 11:04:01][INFO] root register_structure.py:register_common:12 | registering common

 

Share this post


Link to post
Share on other sites

More information about the error

This is the error log

[hquintanaro@PyblishRG ~]$ python2.7 /Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/bin/launcher.py
2018-10-11 13:56:35,786 - ftrack_connect.ui.application.Application - ERROR - Error reaching server url.
Traceback (most recent call last):
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/connect/ftrack-connect/build/lib/ftrack_connect/ui/application.py", line 327, in loginWithCredentials
    allow_redirects=False  # Old python API will not work with redirect.
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/dependencies/site-packages/ftrack_api/requests/api.py", line 69, in get
    return request('get', url, params=params, **kwargs)
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/dependencies/site-packages/ftrack_api/requests/api.py", line 50, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/dependencies/site-packages/ftrack_api/requests/sessions.py", line 465, in request
    resp = self.send(prep, **send_kwargs)
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/dependencies/site-packages/ftrack_api/requests/sessions.py", line 573, in send
    r = adapter.send(request, **kwargs)
  File "/Volumes/Pipeline/televisa-efesto-toolbelt-0.1.0/modules/ftrack/dependencies/site-packages/ftrack_api/requests/adapters.py", line 431, in send
    raise SSLError(e, request=request)
SSLError: Can't connect to HTTPS URL because the SSL module is not available.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0