Jump to content

CentOS 7 Connect No Qt Binding Were Found


Recommended Posts

On a fresh install of CentOS 7.4 I can't run Connect. After the first failure I installed PyQt4, PySide2, and qt4 but still happens.

Traceback (most recent call last):
  File "/home/anthony/Downloads/ftrack-connect-package/library.zip/cx_Freeze__init__.py", line 29, in <module>
  File "/home/anthony/Downloads/ftrack-connect-package/library.zip/ftrack_connect_package__main__.py", line 108, in <module>
  File "/home/anthony/Downloads/ftrack-connect-package/common.zip/ftrack_connect/__main__.py", line 14, in <module>
  File "build/bdist.linux-x86_64/egg/QtExt/__init__.py", line 25, in <module>
  File "/home/anthony/Downloads/ftrack-connect-package/common.zip/Qt.py", line 251, in <module>
  File "/home/anthony/Downloads/ftrack-connect-package/common.zip/Qt.py", line 248, in _init
ImportError: No Qt binding were found.

Any thoughts?

Link to comment
Share on other sites

Yes, libpng-1.5 is installed.


Edit: Update: I've installed a fresh Gnome Desktop centos 7.4 on a virtual machine and Connect throws the same error. Libpng is installed on that as well.

Edited by AnthonyM
Updated info - didn't want to doublepost.
Link to comment
Share on other sites

Which version of Qt.Py are you running?

Can you check if you have PySide or PyQt4 in the PYTHONPATH?

I would suggest setting a debugger in Qt.Py where the error is raised https://github.com/mottosso/Qt.py/blob/master/Qt.py#L1676 and check what you have in the environment at that moment. Try to run the import manually to check if there is an import error.


Link to comment
Share on other sites

It's a clean install of CentOS, so I didn't have anything installed in the path. I've installed PyQt4 4.10.1 and PySide 1.2.4 now. Same error. I opened up the Common.zip and Library.zip, imported those Qt.py's and I didn't get any errors. I can import both PySide and PyQt fine.

I'm confused though, shouldn't the connect package 'binary' downloaded from the downloads page work out of the box without dependencies?

Link to comment
Share on other sites

Hi, I'm experiencing the same issue on a freshly installed Centos 7. I'm trying to launch 0.7.5 from the tarball provided at https://www.ftrack.com/en/portfolio/connect


My Qt.py contains the following at line 235 and onwards:

for binding in bindings:
        _log("Trying %s" % binding.__name__[1:], verbose)

            sys.modules[__name__] = binding()

        except ImportError as e:
            _log(" - ImportError(\"%s\")\n" % e, verbose)



Is this what you wanted to know?


Edit: running python from the terminal, I'm able to import everything Qt.py tries to import, except for the QT5 stuff as I don't have QT5 installed.

Edited by hulmanen
Added detail
Link to comment
Share on other sites

0.7.5 - I've also tried to run it on two different fresh installed vm's with slightly different presets (install groups, like development) to see if that was it.

It prints:

<function _pyside at 0x7ffb1c179b18>

Edit: Also tested 0.7.4 and no go. So weird that this doesn't work.

Edited by AnthonyM
Link to comment
Share on other sites

Libpng12 fixes it for me as well. I second the idea the dependency should be listed in documentation from somewhere. Looking at the installation instructions, it wasn't clear to me that any packages beyond what stock CentOS provides are needed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...