Nuke 11
2 2

4 posts in this topic

Hey,

I was wondering whether Nuke 11 is officially supported?

I have seen various commits/branches on Bitbucket about it, but an initial test showed that Nuke crashes when trying to show any of the "Asset Manager" or "Asset Importer".

Share this post


Link to post
Share on other sites

Hi,

We also have an error with nuke-11 and a previous version of ftrack-connect...

Nuke 11.1v1, 64 bit, built Dec  7 2017.
Copyright (c) 2017 The Foundry Visionmongers Ltd.  All Rights Reserved.
WARNING: Can't select GPU device no GPU available : 0, using device Quadro 4000 : 0
Traceback (most recent call last):
  File "/production/data/software/packages_2.0/ext/ftrack_connect_nuke/0.1.9/payload/resource/nuke_path/menu.py", line 5, in <module>
    import ftrack_connect_nuke
  File "/production/data/software/packages_2.0/ext/ftrack_connect_nuke/0.1.9/payload/build/lib/ftrack_connect_nuke/__init__.py", line 6, in <module>
    import ftrack_connect_nuke.plugin
  File "/production/data/software/packages_2.0/ext/ftrack_connect_nuke/0.1.9/payload/build/lib/ftrack_connect_nuke/plugin.py", line 4, in <module>
    import ftrack_connect_foundry.plugin
  File "/production/data/software/packages_2.0/ext/ftrack_connect_foundry/0.1.0/payload/build/lib/ftrack_connect_foundry/plugin.py", line 6, in <module>
    import ftrack_connect_foundry.bridge
  File "/production/data/software/packages_2.0/ext/ftrack_connect_foundry/0.1.0/payload/build/lib/ftrack_connect_foundry/bridge.py", line 16, in <module>
    import ftrack_connect_foundry.proxy
  File "/production/data/software/packages_2.0/ext/ftrack_connect_foundry/0.1.0/payload/build/lib/ftrack_connect_foundry/proxy.py", line 6, in <module>
    from FnAssetAPI.ui.toolkit import QtNetwork
  File "/production/data/software/packages_2.0/ext/ftrack_connect_foundry/0.1.0/payload/build/lib/FnAssetAPI/ui/__init__.py", line 11, in <module>
    raise RuntimeError("Unable to determine the UI toolkit")
RuntimeError: Unable to determine the UI toolkit

I don't have time to update ftrack-connect just now but will try to do it soon.

 

Share this post


Link to post
Share on other sites

Hi Jerome,  looks like you are having some issues with Qt and / or PySide.

Could you provide some specs about what os you are using , what version and whether you can import  qt and pyside and where are these installed ?

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2