Import Error: No module named collect_playblast_camera error
2 2

8 posts in this topic

I've successfully migrated to 2018 on my local working pipeline. I send my tool to the remote repo, then clone that onto a server location. I do all the setup to get the venv working then run ftrack. Everything is fine at this point. When I run Maya everything works as expected until I get this error:

// Error: No module named collect_playblast_camera
# Traceback (most recent call last):
#   File "<maya console>", line 1, in <module>
#   File "path\to\dependencies\ftrack_connect\resource\connect-standard-plugins\ftrack-connect-maya-publish-0.5.1\resource\maya_plugin\userSetup.py", line 18, in create_publish_menu
#     context_id=os.environ['FTRACK_CONTEXT_ID']
#   File "path\to\dependencies\ftrack_connect\resource\connect-standard-plugins\ftrack-connect-maya-publish-0.5.1\dependencies\ftrack_connect_pipeline\application_plugin.py", line 28, in __init__
#     self.register_assets()
#   File "path\to\dependencies\ftrack_connect\resource\connect-standard-plugins\ftrack-connect-maya-publish-0.5.1\dependencies\ftrack_connect_maya_publish\plugin.py", line 31, in register_assets
#     ftrack_connect_maya_publish.shared_pyblish_plugins.register()
#   File "path\to\dependencies\ftrack_connect\resource\connect-standard-plugins\ftrack-connect-maya-publish-0.5.1\dependencies\ftrack_connect_maya_publish\shared_pyblish_plugins\__init__.py", line 9, in register
#     import ftrack_connect_maya_publish.shared_pyblish_plugins.collect_playblast_camera
# ImportError: No module named collect_playblast_camera //

It's strange because there is a module named collect_playblast_camera in that location. Also, .pyc files are generated for the __init__.py and collect.py files, so it's compiling in that directory until the error.  I've tried a bunch of stuff including straight up copying and pasting my working ftrack connect directory into the cloned one.  I get the same error no matter what.  Any thoughts? Thanks!

EDIT: I think it might have to do with the file path being too long (I'm using windows). The pipeline works fine on my home computer.

Share this post


Link to post
Share on other sites
On 10/3/2017 at 3:42 AM, Mattias Lagergren said:

Are you launching Maya from a downloaded Connect or have you a custom setup?

I download connect onto a server location then use a batch file to launch and set env variables. Does this count as a custom setup?

Share this post


Link to post
Share on other sites

Yes it does. Is connect intended to only work as a local installation?  Are there new environment variables that I'm not setting? With the current setup that used to work, I was able to have everyone launch from connect location on a server. That way I was only managing one installation, instead of several.

Share this post


Link to post
Share on other sites

I cannot see why this would not work for you.  It will run a number of imports and for some reason the second one fails:


    import ftrack_connect_maya_publish.shared_pyblish_plugins.collect
    import ftrack_connect_maya_publish.shared_pyblish_plugins.collect_playblast_camera

If you try to run the "import ftrack_connect_maya_publish.shared_pyblish_plugins.collect_playblast_camera" from the maya script editor I guess it fails too? All the imports can be found here:

https://bitbucket.org/ftrack/ftrack-connect-maya-publish/src/4d944c186b18b038fb8715f8f62ad87436830ff7/source/ftrack_connect_maya_publish/shared_pyblish_plugins/__init__.py?at=master&fileviewer=file-view-default

Share this post


Link to post
Share on other sites

I think I discovered the problem. When I updated my  master version of ftrack connect it looks like some of the modules were gitignored (it's a pesky problem).  So they weren't available on my release directory, but I had them in my dev directory.  I'll verify this tomorrow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
2 2