API: ServerError/AssertionError when committing
1 1

3 posts in this topic

Hi,

 

I created some some costum attributes for a project (in this case of type boolean and text) and tried to set the values via the API, but when committing, I get the message:

ftrack_api.exception.ServerError: Server reported error: AssertionError(Dependency rule tried to blank-out primary key column 'variable_value.entityid' on instance '<Variable_Value at 0x7f8e362ffe90>')

But once I changed the values via the WebUI, then everything works also via the API from this time on. But only for this specific Shot.

 

I already had this problem earlier, but it has disappeared for any reason.

 

Can you help me with this problem?

 

Thanks

Christian

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1