All Activity

This stream auto-updates     

  1. Yesterday
  2. Hi @intelyuxiang as first thing I would check if your machine provides the prerequisites: When Unity start up correctly, you should be having a python interpreter opening in a shell like: and a python process running: Hope it helps. L.
  3. Hi @Andrea Perisano, there's no way to customise the dropdown menu I'm sorry. The way to go is to provide an action which launches your review based on either lists, or components. Hope it helps. L.
  4. Hi, I know how to add and customize action in ftrack, but I was wondering is there a way to play an uploaded media with an external player (in order to play correctly a 360° video degree), without using actions. If possibile to add a custom menu through the ftrack api next to "Launch Web player, "Launch RV", "Launch HieroPlayer", so I can launch my custom application to play that uploaded media? Is good for me just know if possibile to do that, so I can start to work on it! Thanks again for your great work. Andrea
  5. Last week
  6. and how to make sure whether this work
  7. our unity version is 2019.3.8f1. we launched it from unity connector ,and dig into init.cs 's code . it seems that the $"{resourcePath}/scripts/" does not start correctly. we also checked the windows background for this, it did not appear in task manager list.
  8. Environment: MacOS 10.15.4 Python 3.8.1 ftrack-python-api 2.0.0
  9. Hi, When I was trying to connect to event hub (ftrack studio on cloud), I got an exception(paths and domain name have been masked): Traceback (most recent call last): File "-*-/", line 932, in _bootstrap_inner File "-*-8/", line 870, in run self._target(*self._args, **self._kwargs) File "-*-/ftrack_api/event/", line 191, in connect raise ftrack_api.exception.EventHubConnectionError( ftrack_api.exception.EventHubConnectionError: Failed to connect to event server at b'https://-*' with error: "b'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: self signed certificate in certificate chain (_ssl.c:1108)'". But if start session without "auto_connect_event_hub=True" the session can be created. Any clue? Cheers, John
  10. Hello im passing in a spreadsheet into python trying to create many asset builds and folder etc. from this and i keep getting the below error which i believe is because i have multiple objects in the same hierarchy so its trying to create the upper objects int he hierarchy twice, what is the best way you guys have found to catch this or query if that item exists before creating my code it similar to below below ERROR ftrack_api.exception.ServerError: Server reported error: IntegrityError((_mysql_exceptions.IntegrityError) (1062, "Duplicate entry '780a712a-9bc3-11ea-b9ae-d61ccb4e321b-Assets' for key 'context_parent_id_key'") [SQL: u'INSERT INTO context (context_type, name, parent_id, id) VALUES (%s, %s, %s, %s)'] [parameters: (('task', 'Assets', u'780a712a-9bc3-11ea-b9ae-d61ccb4e321b', u'2fec278a-12d1-44fa-8e26-adc3b218a6bf'), ('task', 'Assets', u'780a712a-9bc3-11ea-b9ae-d61ccb4e321b', u'72fd181f-f72d-4f87-9cd8-74e579cfa588'), ('task', 'Assets', u'780a712a-9bc3-11ea-b9ae-d61ccb4e321b', u'9261c102-080b-45c6-9a07-d3e4eeca3fc1'))] (Background on this error at: [Finished in 21.9s] CODE: task = FTrack_session.create(object_type,{'name':object_name,'parent':FTrack_object_parent})
  11. I have not tried the first solution. The second one does not work. I found a solution to this. session.reset() Using session.reset() to replace session.cache.clear() seems working fine for me now. Thanks for the help, Lorenzo.
  12. Hi @chengshun neither does adding the notes in the projection ? entity_ins = self.session.query('select notes from AssetVersion where id is %s' % sel_id).first()
  13. Thanks, Lorenzo I'm sorry but It doesn't work. I tried the session.populate(project, 'notes'), but the result is same as not using the code, just like before when I didn't add cache.clear(). Newly created notes were removed. Seems like the session data is not updated. The code I've changed is like below:
  14. Is there a way to query or export a list of permissions for each role? I'm trying to create a spreadsheet that shows by role, what the permissions are. I am currently having to take multiple screenshots (because of the modal window) and then would have to type these in all by hand. Or is it possible to get a list of all of the permissions so that I can more easily create/fill in this spreadsheet manually?
  15. Earlier
  16. Is there still a plan to implement this? Would it possible to at the very least add users with Ftrack accounts by searching for them to take part of the manual process out of it? Cloning is helpful in some situations but doesn't solve the issue for large scale projects.
  17. @chengshun we have been further looking into the reported issue. One thing you can try is to replace the session.cache.clear() call with session.populate(project, 'notes') Please let us know if does solve your problem. Cheers. L.
  18. Hi @chengshun resetting the cache half way through the action is risky at least. Something you can try is to rework the query you are doing as such: entity_ins = self.session.query('select notes from AssetVersion where id is %s' % sel_id).first() here you can find one of our examples which shows you how to use the use of ftrack-action-handler and how to attach the result document to the job itself ,so you don't have to save it , hope it helps. if you are still having issues please let us know. L.
  19. Hello, sorry to re-up this topic, but have you any ETA on this feature ? Will we be able to manage in settings the number of decimal digits ? As we do for version number padding :) we can manage some assets attributes with almost 4 or 5 digits behind the coma (displacement values on very precise materials) For the moment we are using text attribute as work-around, but it would be safer (avoid typing mistakes) to use numerical one. Thank you very much :)
  20. Hi @intelyuxiang, would you mind trying against the latest master on cone the repository with: git clone then from within the cloned folder run : python build_plugin this will create an up to date version of the integration. Please also ensure you Unity Hub has been stopped before re running the integration. Let us know how it goes. L. Ps. Also can you report back what Unity version are you using ? thanks.
  21. Package from git URL 。unity 1.0.0 -rc2 Error: FtrackException: The ftrack client could not connect successfully. UnityEditor.Ftrack.ConnectUnityEngine.Client.EnsureClientProcess () (at Library/PackageCache/ftrack-connect-unity-plugin@5d73de1e73/Editor/Init.cs:143) UnityEditor.Ftrack.ConnectUnityEngine.Client.EnsureClientProcess () (at Library/PackageCache/ftrack-connect-unity-plugin@5d73de1e73/Editor/Init.cs:139) UnityEditor.Ftrack.ConnectUnityEngine.Client.EnsureClientProcess () (at Library/PackageCache/ftrack-connect-unity-plugin@5d73de1e73/Editor/Init.cs:139) UnityEditor.Ftrack.ConnectUnityEngine.Init.InitFtrack () (at Library/PackageCache/ftrack-connect-unity-plugin@5d73de1e73/Editor/Init.cs:189) UnityEditor.EditorApplication.Internal_CallDelayFunctions () (at <bd2913165a514bbe8b0dffcb5ea8ff39>:0)
  22. Hi, I was working on a event action script. It is used to collect all notes under one assetVersion and convert them to a doc which will be added to a new note. It works fine at first. But I found that it can not collect new notes which are created after the starting time of the event script. So I think the problem may be the session cache. Then I add a code to clear the session: session.cache.clear() at lunch function. But error shows up: ERROR:ftrack_api.event.hub.EventHub:Error calling subscriber <Subscriber metadata={'id': '723b56730bde4abe81f3c732303f2e9f'} subscription="topic=ftrack.action.launch and data.actionIdentifier=sy.notes-to-docx"> for event <Event {'topic': u'ftrack.action.launch', 'source': {u'id': u'6347029859d2401bb850f5fada92295c', u'user': {u'username': u'chengshun', u'id': u'bcdf57b0-acc6-11e1-a554-f23c91df1211'}}, 'target': u'', 'data': {u'actionIdentifier': u'sy.notes-to-docx', u'selection': [{u'entityId': u'ac013aa4-9065-11ea-bda8-0a58ac1e069e', u'entityType': u'assetversion'}], u'label': u'Notes To Docx'}, 'in_reply_to_event': None, 'id': u'32a6a71deed7415f9e9f9b35277c30ac', 'sent': None}>. Traceback (most recent call last): File "c:\Python27\lib\site-packages\ftrack_api\event\", line 724, in _handle response = subscriber.callback(event) File "D:\git\shenyin_pipeline\ftrack\", line 98, in launch location=server_location File "c:\Python27\lib\site-packages\ftrack_api\", line 1956, in create_component 'FileComponent', path, data, location File "c:\Python27\lib\site-packages\ftrack_api\", line 2025, in _create_component origin_location.add_component(component, path, recursive=False) File "c:\Python27\lib\site-packages\ftrack_api\entity\", line 78, in add_component [component], sources=source, recursive=recursive File "c:\Python27\lib\site-packages\ftrack_api\entity\", line 139, in add_components details=dict(location=self) LocationError: No structure defined for location <Location(ce9b348f-8809-11e3-821c-20c9d081909b)>. And the error comes from the code session.create_component() I use cache.clear() at another event action script to create folders at the studio network storage and it works fine. Seems like only create function will go wrong after cache.clear(). I put the full script below. Need some help, thanks.
  23. Hi Janis, Which browser/os/and part of ftrack are you seeing the issue with? I tried a quick test in Chrome on macOS and Windows 10 in the task spreadsheet and while editing a note and I didn't notice anything surprising.
  24. Hi Ozen, If you mean grouping by types, this might help: Unfortunately I don't believe you can limit a view to a particular type however.
  25. Hey Peter, nice work! I've been thinking about something like this myself--I love tab-completable everything and am excited to give this a try.
  26. Ah ok, so it's not actually storing as a list. Great, thank you!!!
  27. +1 for this request. Integrations like this are essential to project management nowadays.
  28. Hello, I am trying to create a view where I can see all the milestones and tasks for a specific department. Example: all Tasks and Milestones for Compositing. When I go to filters I can only filter by Milestone Type OR Task Type, there are no options for Department. If I add both, they negate one another. When I go into the advanced filter options it only allows me to use Task for the "Any condition". In the past Milestones were the same as tasks with no duration which made this easier. Any help would be greatly appreciated! Thank you! Ozen
  1. Load more activity