All Activity

This stream auto-updates     

  1. Today
  2. Hi @Alican you cannot use the location.get_url(component) as path for the component as is relative to the server, path requires to be a local path to your file system. What you might be after, if I'm getting it right , is an event which collect the data which might have been manually uploaded and then transfer them first to you local disk , before being re uploaded as reviewable. For this to work , you need to have a listener running which will intercept the update event for components and use that to move the data from the ftrack.server to the local storage. Something along these lines should work ( Hope it helps. L.
  3. Hi Andrea, Thanks for valuable feedback. We are looking at enhancements on this, so I have added your input to that task. Also, I moved this thread to ftrack Studio/Feature requests. Regards, Johan
  4. Yesterday
  5. Just to add on, In the end, I would like to have a system that works just like drag and dropping the mov file to the Versions area of the task.
  6. Hello all, I've been trying to upload an existing .mov file to ftrack for review, I've made quite a progress using the examples provided, however I'm stuck at the component part. At the moment, it submits an encoding job, waits for the job to be done, and gives me the URLs of the paths. If I set the path key on the create_component() to the MOV_FILE, it uploads. but if I set it to the url of the encoded item, it gives me the error below. What am I doing wrong? When I inspect the link from the line that says Resoruce not found, I can see that it does exist. and it downloads a file called, which is exactly what I want. This tells me that this resource indeed exists in the server. The following is a standalone script that gets the MOV_FILE and uploads it as an asset for a task(TASK_TYPE) that belongs to a shot (SHOT_NAME). import os, sys import subprocess import time import getpass import ftrack_api import json os.environ['FTRACK_SERVER'] = FTRACK_SERVER os.environ['FTRACK_API_USER'] = getpass.getuser() os.environ['FTRACK_API_KEY'] = FTRACK_API_KEY session = ftrack_api.session.Session(auto_connect_event_hub=True) SHOT_NAME = 'CHM201_033_050' TASK_TYPE = 'Compositing' MOV_FILE = 'Q:/Charmed_S2/CHM201/07_DAILIES/SLATED_OUTPUTS/offline/AVdn/' shot = session.query('select name, id from Shot where name is {}'.format(SHOT_NAME)).first() comp = session.query('select name, id from Task where is {} and is {}'.format(shot['id'], TASK_TYPE)).first() mov = MOV_FILE task = session.get('Task', comp['id']) asset_parent = task['parent'] job = session.encode_media(mov) job_data = json.loads(job['data']) print 'Source component id', job_data['source_component_id'] print 'Keeping original component', job_data['keep_original'] location = session.query('Location where name is "ftrack.server"').one() for output in job_data['output']: print u'Output component - id: {0}, format: {1}'.format( output['component_id'], output['format'] ) #Wait for the job to complete keep_waiting = True timer = 0 wait = 5 while keep_waiting: print 'waiting.. {} seconds'.format(timer) time.sleep(wait) timer+=5 listen_session = ftrack_api.session.Session(auto_connect_event_hub=True) the_job = listen_session.query('Job where id is{}'.format(job['id'])).first() if the_job['status'] == 'done': print 'proceeding...' keep_waiting = False location = session.query('Location where name is "ftrack.server"').one() #Print out the urls and test them to make sure they exist for component in job['job_components']: component_name = component['component']['name'] print component_name, location.get_url(component) asset_type = session.query('AssetType where name is "Compositing"').one() asset = session.create('Asset', { 'name' : 'Compositing Asset v7', 'type': asset_type, 'parent': asset_parent }) asset_version = session.create('AssetVersion', { 'asset': asset, 'task': task }) for component in job['job_components']: component_name = component['component']['name'] print component_name, location.get_url(component) if component_name == 'thumbnail': new_component = asset_version.create_component( path=location.get_url(component), data={ 'name': 'thumbnail' }, location=location ) if component_name == 'ftrackreview-mp4': new_component = asset_version.create_component( path=location.get_url(component), data={ 'name': 'ftrackreview-mp4' }, location=location ) session.commit() Thank you for all your help as always! Ali
  7. Our actions are all in a shared location mapped through the FTRACK_CONNECT_PLUGIN_PATH. I am not running any listeners at the moment, and when I do it runs locally from my machine and not the shared location. When this happens I usually don't have a listener running. When and if this issue comes up again, I will try removing all actions & events and see if that helps. Thank you!
  8. Hi Mattias, Can you please let me know if this is still in the works? I have changed companies, but would still like to see this implemented. Thank you! ozen
  9. Hi, You mentioned statuses - could you elaborate on that? Depending on the use case, there might be other possible feature enhancements involved. Regards, Johan
  10. Last week
  11. HI @Alican just gave it a go with default connect and actions and I can see them appearing on both Chrome instances I've open (application launchers). May I ask where the actions are hosted ? On each ftrack-connect-package plugin folder (local to the user) , in a shared place and mapped through FTRACK_CONNECT_PLUGIN_PATH / FTRACK_EVENT_PLUGIN_PATH or are running as standalone event listeners ? Also, to help us investigate, removing custom events and actions does still trigger your issue ? Looking forward to hear more from you . L.
  12. Hello, I would like to request better customization of "My tasks" section. I would welcome the same features and filters that are available in overview dashboards. We could select by which date it's supposed to be showing (for example tasks sorting according to start date except for the default due date) also we could adjust the width of columns, check to see the notes directly in the my tasks section withouth opening the task and checking notes section etc. Also so we could save these my tasks for users/or they could adjust it generally to their needs.
  13. Download 0.2.3 Originally written by Mike Datsik What's new * Ensure loads correctly under latest version of houdini (18.0) * Update to latest QtExt to Fix QStringListModel compatibility for PySide2 5.9+. * Update plugin built for pip 19+ * Update icon path How to install stop ftrack-connect-package download and uncompress the new version in : <ftrack-connect-package>/resource/connect-standard-plugins/ restart ftrack-connect-package
  14. Hi Angelique, Welcome to the forum. Thanks for sending this in. You should be able to use "Adjust to bid" on multiple tasks. So I have reported this as a bug. We will look at a fix for the behaviour. Regards, Johan
  15. No box at all. We are all in the same project, however not all in the same context. When it breaks on me, it breaks everywhere regardless of project or selection context. And everyone can still access the actions on any context on any project. Everyone is logged with their own credentials. But it seems user related since I can log in from a different machine using my ftrack credentials, and it still wont show up. And when it fixes itself, I am able to access the actions menu from any computer. I was able to replicate my problem by having multiple (2) ftrack web pages open. I am logged in as the same user on both of them. It works on one of them (the first one I had open) and it doesn't work on the other. I just closed down my Chrome entirely, and also quit the Ftrack-Connect app. I restarted everything, and actions box still not appearing.
  16. Earlier
  17. TDArlt

    Gantt Chart - export

    A small update for everyone listening here: I've made the first steps for creating the Gantt-exporter. It's not finished, but might be sufficient for some of you already: I will keep you updated 🙂
  18. Hi Eric, Thanks for reporting this. I have reported it to the team as a bug. You can send bug reports to support if you want. Regards, Johan
  19. Hi Alican, Are you experiencing an empty box for actions or no box at all? When you look at others, where it works, are you in the same project and same context? Regards, Johan
  20. Hi Andrea, Thanks for reporting this. Seems that the dashboard is not using correct time for the date. I have reported the behaviour to the team. Regards, Johan
  21. Hello, found a bug on enumerator (Single selection) attribute when exporting to excel (whatever the format) My values are thoses ones : Ceramic value1 Concrete - Asphalt value2 Fabric value3 Ground value4 Leather value5 Marble - Granite value6 Metal value7 Organic value8 Paint value9 Paper value10 Plaster value11 Plastic - Rubber value12 Stone value13 Terracotta value14 Translucent value15 Wood value16 Foliage value17 Flowers value18 Sticks - Branches value19 Insects - Seashells value20 Rock - Pebbles value21 Debris value22 Hardware value23 Sorry it is long So here the bug is, A : If i have Stone (value13) on an asset, ftrack will export this data: "Ceramic, Stone" B : If i have Debris (Value22) on an asset, ftrack will export this data: "Concrete - Asphalt, Debris" It seems that ftrack take the first number and, also the full number instead of taking only the full number. So in A, it give values 1, 13 and in B, it give values 2, 22 Thanks Eric ps: where do we report bugs ?
  22. Hello I'd like to know if there is a way of applying the Adjust to bid (right clic drop down menu on a task) to multiple tasks at the same time. I tried holding ctrl key and selecting many tasks but the right clic > adjust to bid doesn't work at all of them. Does this feature exist ? If not, can we implement it please, as it is very efficient when you have 500 tasks project to adjust to bid at once. Thank you very much
  23. Hello Everyone! Sometimes, (like right now) Actions menu will not show up when I click on Actions. Other users in my studio is able to use it just fine. I tried doing the same steps from a different computer, and it wont show up on those either. So far I've tried different browsers, clearing cache on Chrome (Which is the browser we all use 99% of the time), and relaunching the Ftrack-Connect on the desktop., and restarting my computer numerous times. Has anyone else had this issue in the past, and how was it resolved? Thank you in advance!!
  24. Invited! Regards, Johan
  25. Hi Kay, which OS are you using? It works fine for me on OSX. Does the action work correctly on previous versions of Photoshop? Can you verify that you have published a PSD file to the task you have selected in Connect?
  26. Thanks, Lucas! It seems like I did not try this, although it totally makes sense - and works perfectly.
  27. Thanks for the quick fix on the docs, certainly clears up some confusion I had, haha. Regex would be very appreciated and powerful. I am also facing a need to validate statuses though, so I wonder if there's a way for a regex to apply to that field as well. It would be a little more abstract than than naming validation I guess, but I could see it still working. That may be out of scope though, if the discussion here is determined to be focused purely on validating text fields or something. The way that old validate function worked seems to be the right idea implementation-wise. I understand if the new API ruled out that type of event interception though. Overall the need seems to be having the chance to validate an event before it actually happens. That's the common thread with all of these issues - the fact that currently ANY validation needs to be the product of detecting a change and reverting it, as well as completely custom logic, is quite daunting and taking up a decent amount of my development time. I'm not familiar enough with the API yet to be thinking about performance, but I'm sure that would increase too when we aren't reverting so many changes.
  28. Hi Johan, Could you please send me an invite? Cheers, Roy
  1. Load more activity